16Déc.2016

Prestashop 1.7 : faut-il foncer ou attendre ?

Dans le e-commerce comme dans l’informatique en général, les nouveautés sont toujours très attendues. Chez Ukoo, nous nous sommes depuis plusieurs années spécialisés sur Prestashop pour les boutiques e-commerce. Avec plusieurs dizaines de projets à notre actif, nous sommes aujourd’hui Partenaire Prestashop Platinum.

Vous pouvez donc vous douter que nous suivons de près les évolutions Prestashop…

En cette fin d’année, l’arrivée de Prestashop 1.7 est un véritable événement. Mais faut-il pour autant changer de version au plus vite ? Nos experts vous répondent.

_guillaume

L’avis de Guillaume, notre chef de projet e-commerce :

Depuis sa sortie, Prestashop 1.7 n’en finit pas de susciter l’intérêt de nos clients, et on les comprend !

Code Better, Create Easier, Sell Faster, tels sont les maîtres mots de cette nouvelle version qui a de quoi séduire : starter thème plus souple, back-office simplifié et plus ergonomique, ajout rapide de nouveaux produits, tunnel de commande plus performant (exit le processus de commande en 5 étapes), l’interface utilisateur a été entièrement repensée pour faciliter le quotidien des e-commerçants.

Que l’on soit utilisateur, intégrateur ou développeur, les perspectives de Prestashop 1.7 donnent envie !

Une fois passée l’euphorie de l’annonce se pose alors une question légitime : faut-il passer à Prestashop 1.7 ?

Sachez tout d’abord que rien ne presse. La version 1.6 et sa récente mise à jour en décembre demeurent une valeur sûre qui sera maintenue jusqu’en octobre 2018, de quoi envisager l’avenir sereinement.

Vous pourrez profiter de ce laps de temps pour préparer votre migration vers Prestashop 1.7 car il ne faut pas perdre de vue qu’il s’agit d’une version majeure. Quelques précautions seront donc nécessaires et il sera préférable d’être accompagné avant de vous y aventurer. En effet, les modules n’ont pas encore tous été mis à jour et les anciens thèmes ne sont pas compatibles avec la nouvelle architecture. Vous n’aurez d’autre choix que d’utiliser un nouveau thème compatible.

Il apparaît donc clairement qu’il vaut mieux en créer un sur mesure ou d’utiliser le thème de base. Le passage à la version 1.7 est donc à considérer comme un réel projet de refonte.

_alexandre

L’Avis d’Alexandre, notre intégrateur / développeur Front :

Avec l’arrivée de cette nouvelle version, Prestashop met à disposition un nouveau thème nommé « Classic ». C’est le seul thème présent par défaut et activé à l’installation de Prestashop. C’est l’équivalent du thème « Default-Bootstrap » de la version 1.6 mais revu et adapté à cette version pour gérer les nouvelles fonctionnalités.

En parallèle, Prestashop propose une nouveauté nommée “Starter Theme”, qui est une base de départ “brute” (sans aucune surcouche graphique) qui permettra de créer un thème entièrement personnalisé et correspondant à vos besoins sans devoir bricoler le thème “Classic” natif. Le “Starter Theme” simplifiera donc la création d’un nouveau thème mais ce dernier se destine aux pros comme les concepteurs de thèmes, développeurs et intégrateurs.

Les thèmes 1.6 ne seront donc plus compatibles avec la version 1.7 (Prestashop 1.7 est une nouvelle version “majeure” comprenant une nouvelle architecture, ce n’est donc pas une simple “mise à jour”). Si vous tentez une mise à jour de votre Prestashop en version 1.7 vous perdrez votre thème personnalisé actuel et le nouveau thème « Classic » sera activé (et je n’aborde ici que  la problématique du thème, n’étant que la partie immergée de l’iceberg ^^).

Vous comprendrez donc que mettre à jour votre boutique vers la version 1.7 impliquera d’acquérir ou de concevoir un nouveau thème qui vous correspond. La mise à jour de votre Prestashop sera donc un nouveau projet à part entière et devra passer par des phases complexes de migration que ce soit au niveau du thème, des modules ou de la base de données. En résumé, oubliez la notion de « Mise à jour One-Click » ! Pour utiliser cette nouvelle version Prestashop 1.7 un projet complet de refonte est donc à prévoir, pour certains ce sera peut être l’occasion d’améliorer ou repenser votre thème et ainsi proposer de nouvelles fonctionnalités à vos internautes. L’agence Ukoo sera bien sûr là pour vous accompagner dans cette démarche.

Mais n’ayez crainte, si vous êtes en version 1.6, cette dernière ne sera absolument pas caduque et sera suivie jusqu’à fin 2018, ceci illustre bien le fait que la mise à jour vers cette version n’est pas nécessaire si vous avez déjà une boutique fonctionnant en version 1.6. Gardez en tête que le chantier et le coût important qu’impliquerait le changement de version de votre boutique vers la 1.7 (sans véritable raison ou besoin spécifique) n’est pas à prendre à la légère et ne doit surtout pas être réalisé sur un coup de tête. N’hésitez pas, nous sommes là pour en discuter avec vous et vous orienter au mieux en fonction de vos besoins.

_frederic

L’AVIS De frederic, NOTRE responsable technique et commercial :

Pour conclure, même si de notre point de vue, il serait plus prudent d’attendre plusieurs mois d’avoir une version 1.7 éprouvée par la communauté et sécurisée au maximum pour l’utiliser concrètement en production, il est peut être intéressant pour vous d’envisager cette nouvelle version si vous êtes actuellement en phase d’étude pour lancer une nouvelle boutique en ligne courant 2017.

Toutefois si vous partez d’une version précédente et vous portez sur la version 1.6, celle-ci vous apportera tout de même de nombreux avantages fonctionnels.

L’essentiel réside aussi dans la capacité de votre partenaire web à maîtriser la solution technique qu’il vous proposera.

On compte encore plusieurs clients qui exploitent des anciennes versions telle que la 1.4 ou 1.5 et se lancent sur 2017 dans une évolution de leur plateforme en version 1.6 afin de minimiser les risques face à une version 1.7 encore trop fraîche.

Inutile de vous rappeler, comme à l’habitude d’une communauté PrestaShop très active et pleine de bonnes idées que la version 1.7 est l’occasion d’évolutions techniques majeures et progressives qui risquent fortement de perturber toute approche sereine d’un projet sur cette version durant les 6 à 8 premiers mois de sa parution.

Préservez-vous donc de la versionnite aigüe, pathologie bien connue, échappée il y a quelques décennies d’un laboratoire secret d’une grande firme informatique…

En cas de symptômes ou pour toute information et projet, n’hésitez pas à consulter notre équipe (prioritairement par email afin d’éviter toute infection.)

 

Il y a 10 commentaires

  • Webbax

    Hello,

    Merci pour ce partage d'avis.

    Actuellement il faut que la migration se justifie, car les différences entre Prestashop 1.6 et 1.7 ne sont pas "révolutionnaires", que ça soit au niveau de l'utilisation ou au niveau de l'interface client.

    Mon conseil serait de continuer à optimiser la boutique Prestashop 1.6 et d'envisager de réfléchir à une stratégie "simple" (côté marchand) pour la version 1.7, de manière à faciliter aussi les migrations de contenu par la suite.

    Mon conseil est aussi de limiter un maximum les modules externes, quand cela est possible.

    A bientôt !

  • Prestarocket

    Hello,

    Je suis plutôt pessimiste sur le suivi de la 1.6 vu le peu de developpeurs chez prestashop travaillant sur le coeur. De notre côté on tente le pari d utiliser la 1.7 sur les nouveaux projets puisque nous utilisons pas de thèmes achetés. Le gros plus de la 1.7 est le thème par défaut avec son tunnel très reussi

  • cocodyRockstar

    Bonjour et merci pour cet article.

    Si vous deviez vous lancer dans un tout nouveau projet avec prestashop, le feriez vous avec la 1.7? ou au contraire avec une version antérieure?

    • Frédéric Vogel

      Bonjour,
      Au stade actuel de la version 1.7 nous restons encore sur la 1.6.1.x, trop de modules indispensables ne sont pas encore compatibles.
      Mais la roadmap annoncée par PrestaShop promet de belles avancées d'ici 4 à 6 mois. En attendant, nous préférons rester dans le périmètre du "connu & rodé"

  • stef

    Bonjour,

    Une question peut-être bête, est-ce qu'il est possible de passer par exemple de la version 1.5 à la version 1.6 pour faire une mise à jour du CMS, sans utiliser la version 1.7 pour le moment ?

    Merci

  • Domi

    Salut, mon expérience avec prestashop 1.7 est une catastrophe, rien est compatible avec rien, entre module pourtant 1.7 et template 1.7 rien ne va plus. Mon avis est dont tres négatif, c'est peut être encore trop tôt… je retourne sur prestashop 1.6

  • Cilou31350

    Bonjour à tous,

    Dans le cadre d'un nouveau projet et après de longues réflexions (incluant mon client) j'ai décidé de partir sur la 1.7 avec un bon thème que je connaissais et qui est donc lui aussi passé en version 2. Malheureusement, c'est la galère 🙁 Bugs en série, manque de modules compatibles, le logiciel de caisse connecté n'est toujours pas prêt (le dév m'annonce son développement en cours mais je me demande s'ils ont bien pris la mesure du boulot qui s'annonce et seront prêt à temps).
    Résultat : je repars sur la 1.6 avec l'ancienne version du thème et l'install du module logiciel caisse compatible.
    J'ai prévenu mon client que 1.6 ne sera plus mis à jour à partir de nov 2018. Mais je me pose une question, faut il envisager un passage à 1.7 dès nov 2018 ou sera-t-il possible de laisser passer encore quelques mois ? Avez-vous des avis éclairés sur la question ?
    Merci

    • Frédéric Vogel

      Bonjour,
      Le vieil adage "Prudence est mère de sûreté" s'applique toujours quand il s'agit de partir en production, voilà pourquoi nous continuons à utiliser PrestaShop 1.6.
      Nous gardons un œil attentif sur la stabilisation de la version 1.7 qui arrive doucement à maturité.
      Quand à l'échéance du suivi de maintenance de la 1.6 à l'automne 2018, cela laisse un peu de marge de manœuvre.
      Ce qu'il faut entendre c'est que cette version sera maintenue jusqu'à cette date, mais rien n’empêchera la boutique de fonctionner.
      Certes, elle pourra se retrouver moins fiable d'un point de vue sécurité, mais rien d'alarmant si l'on se munit de quelques outils de sécurité coté hébergement/serveur et d'une maintenance pro-active.
      On a quelques clients qui utilisent encore une version 1.4 ou 1.5 qui fonctionnement parfaitement et attendent la 1.7 validée par notre équipe.
      Tout comme d'autres que l'on à porté récemment sur une version 1.6 avec des résultats très satisfaisant lors d'une refonte après 2 à 3 ans d'utilisation d'une version pouvant être jugée "obsolète".

      • Cilou31350

        Merci Frédéric pour cet avis pertinent et professionnel et le retour d'expérience qui éclaire ma lanterne 🙂

  • Kzink

    Bonjour
    J'utilise actuellement pour mon E-boutique la version 1.5.5.0 mais je rencontre de nouvelles difficultés avec le module Prestashop Bank wire V0.7.2 qui ne fonctionne plus et envoi mes clients sur une page d'erreur.
    Trois questions se posent :
    Le soudain non fonctionnement du module Bank wire de Prestashop est-il lié à la version utilisée 1.5.5.0 ?
    Est-il possible de "réparer" cela ?
    Dois-je passer mon E-boutique sur Prestashop 1.7.2.2, faire le grand saut et tout reprendre ?
    Dans l'attente de vos réponse, recevez, mes cordiales salutations.
    Philippe

Laisser un commentaire

*